KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Disabling commands by saying "disable"
Topic Summary: Is not working
Created On: 10/15/2020 06:16 AM
Status: Post and Reply
Linear : Threading : Single : Branch
 Disabling commands by saying "disable"   - Anandits - 10/15/2020 06:16 AM  
 Disabling commands by saying "disable"   - Lunis Orcutt - 10/15/2020 11:22 AM  
 Disabling commands by saying   - Anandits - 10/15/2020 10:34 PM  
 Disabling commands by saying   - Lunis Orcutt - 10/16/2020 01:57 PM  
 Disabling commands by saying   - Anandits - 10/19/2020 03:02 AM  
 Disabling commands by saying "disable"   - Lunis Orcutt - 10/19/2020 11:23 AM  
 Disabling commands by saying "disable"   - nogods - 11/23/2020 01:42 PM  
 Disabling commands by saying "disable"   - dilligence - 11/23/2020 03:07 PM  
 Disabling commands by saying "disable"   - Lunis Orcutt - 11/23/2020 06:16 PM  
 Disabling commands by saying   - Edgar - 11/23/2020 04:55 PM  
Keyword
 10/15/2020 06:16 AM
User is offline View Users Profile Print this message

Author Icon
Anandits
Senior Member

Posts: 126
Joined: 03/25/2019

I have updated my KnowBrainer commands to build 10/1/2020, and according to the documentation it should be possible to disable comments by selecting them and saying "disable". This is not working for me, it does open the editor, (after quite a long wait), and then nothing. I actually got it to working once, but neither before or after.

 10/15/2020 11:22 AM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38354
Joined: 10/01/2006

Currently, whenever you edit or create a KnowBrainer global command, such as enabling a <DISABLED> xxx command, it takes 20 seconds to deploy the command the 1st time. If you wait 20 seconds, it will probably work but that would be unnecessarily painful. Thanks to a recent Windows 10 update, which includes a nasty bug, we have run into this issue which has nearly been fixed. We will re-release KnowBrainer at that time. Fortunately, you can manually enable <DISABLED> commands. The KnowBrainer Enable command simply opens any <DISABLED> command, removes <DISABLED> from the name and saves it. In other words all you have to do is rename your command.



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1

 10/15/2020 10:34 PM
User is offline View Users Profile Print this message

Author Icon
Anandits
Senior Member

Posts: 126
Joined: 03/25/2019

Thank you, yes, I know I can rename commands manually, this seemed like a nice quick way to do it.

Every time when I update the KnowBrainer commands it takes me a lot of time to import my own commands again. It would be so wonderful if at some point it would be possible if the import function will just highlight any command that is not in the newer version, as well as any command that might be changed.... It is also very difficult to do this by voice alone, so it is a painful exercise.
I know you have talked about making the import process easier at some point, I look forward to the time when that will be the case!
 10/16/2020 01:57 PM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38354
Joined: 10/01/2006

Delay fixes are possibly only a few days away. A much easier feature to export and import personal commands are planned for the KnowBrainer 2021 release. 



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1

 10/19/2020 03:02 AM
User is offline View Users Profile Print this message

Author Icon
Anandits
Senior Member

Posts: 126
Joined: 03/25/2019

Good to hear that.
Since I updated to version 10-01-2020, the command 'computer' renders 'yes captain' again (instead of "working"), I thought this was outdated. Or is this command reverted to something older?
 10/19/2020 11:23 AM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38354
Joined: 10/01/2006

We changed the Computer command to respond with “yes captain” so that we could hear if our customers were using a more recent KnowBrainer Build, over the phone.



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1



 11/23/2020 01:42 PM
User is offline View Users Profile Print this message

Author Icon
nogods
New Member

Posts: 7
Joined: 11/22/2019

Originally posted by: Lunis Orcutt We changed the Computer command to respond with “yes captain” so that we could hear if our customers were using a more recent KnowBrainer Build, over the phone.

 

how to I cahnge that so that when I say "computer" it types "computer" as dictation rather than responding?

 11/23/2020 03:07 PM
User is offline View Users Profile Print this message

Author Icon
dilligence
Top-Tier Member

Posts: 1220
Joined: 08/16/2010

Locate the command in the KB Sidebar and change the contents to this:

 

 

 



-------------------------

www.speechproductivity.eu 


Auto Box - SP Editor - HyperNotes - Pause Reminder - Speaker - Quick Correct - Easy Guide to Dragon Scripting

 11/23/2020 06:16 PM
User is online View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38354
Joined: 10/01/2006

You will find additional options here



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1

 11/23/2020 04:55 PM
User is offline View Users Profile Print this message

Author Icon
Edgar
Top-Tier Member

Posts: 984
Joined: 04/03/2009

I think it would be better to delete the offending command.

-------------------------

-Edgar
DPI 15.3, 64-bit Windows 10 Pro, OpenOffice & Office 365, Norton Security, Shure X2U XLR to USB mic adapter with Audio Technica DB135 vocal mic, Asus X299-Deluxe Prime, Intel Core i9-7940X (14 core, 4.3 GHz overclocked to 4.9 GHz), G.SKILL TridentZ Series 64GB (4 x 16GB) DDR4 3333 (PC4 26600) F4-3333C16Q-64GTZ, NVIDIA GIGABYTE GeForce GTX 1060 GV-N1060G1 GAMING-6GD REV 2.0 6GB graphics card with 3 1920x1080 monitors

Statistics
31883 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 2 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 507 guests browsing this forum, which makes a total of 509 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.