KnowBrainer Speech Recognition
Decrease font size
Increase font size
Topic Title: Vocola 2 disable dictation in commands file?
Topic Summary:
Created On: 01/18/2021 03:09 PM
Status: Post and Reply
Linear : Threading : Single : Branch
 Vocola 2 disable dictation in commands file?   - renegadevoice - 01/18/2021 03:09 PM  
 Vocola 2 disable dictation in commands file?   - mdl - 01/18/2021 08:50 PM  
 Vocola 2 disable dictation in commands file?   - renegadevoice - 01/21/2021 06:46 AM  
 Vocola 2 disable dictation in commands file?   - Lunis Orcutt - 01/21/2021 12:58 PM  
 Vocola 2 disable dictation in commands file?   - renegadevoice - 01/22/2021 04:53 PM  
 Vocola 2 disable dictation in commands file?   - alexander - 01/25/2021 08:59 PM  
 Vocola 2 disable dictation in commands file?   - renegadevoice - 02/01/2021 09:34 AM  
Keyword
 01/18/2021 03:09 PM
User is offline View Users Profile Print this message

Author Icon
renegadevoice
New Member

Posts: 4
Joined: 01/18/2021

In Vocola 2 with Dragon, can you disable dictation for a given window and also use commands?

 

In Vocola 3, I can just put on the first line (for instance, for Anki)

onLoad() := Dictation.DisableForWindow(anki, Anki);


Is there something similar in Vocola 2 / Dragon macros? I much prefer Dragon over Windows Speech Recognition and want to use Vocola 2, and the typed in commands work just fine (eg "Good = {enter};", but when it does NOT recognize a command it just sends dictation to the program which causes random windows to open (presumably due to triggering a hotkey on that program)

 01/18/2021 08:50 PM
User is offline View Users Profile Print this message


mdl
Top-Tier Member

Posts: 832
Joined: 04/18/2009

maybe <_anything> = Beep(); or the like will work

alternatively, you can switch Dragon to command only mode while using those windows
 01/21/2021 06:46 AM
User is offline View Users Profile Print this message

Author Icon
renegadevoice
New Member

Posts: 4
Joined: 01/18/2021

So I see the option for disabling dictation for unsupported apps, but is there another setting for only ever using commands? That's what I was looking for overall

 

in the meantime, I'll try that other command you posted. Thanks!

 01/21/2021 12:58 PM
User is offline View Users Profile Print this message

Author Icon
Lunis Orcutt
Top-Tier Member

Posts: 38522
Joined: 10/01/2006

You can place Dragon into Command Mode (only) by saying switch to command mode or manually switch via the DragonBar menu.



-------------------------

Forum Mission Statement
Trial Downloads
Dragon/Sales@KnowBrainer.com 
(615) 884-4558 ext 1

 01/22/2021 04:53 PM
User is offline View Users Profile Print this message

Author Icon
renegadevoice
New Member

Posts: 4
Joined: 01/18/2021

so putting this in

<_anything> = Beep();

seems to just cause all commands in the file to not work (not sure if it's because this acts as a global fallback or something)

I'm using Dragon 15 Home - does this version not work with those kinds of commands? Dragon seems to recognize me saying "switch to command mode" (at least when it's in the dictation pad it shows that), but it doesn't actually seem to do anything

Tools menu in top looks like this if that helps; options menu is pretty slim and doesn't talk about command mode or anything else that I can see

 

edit: I only used the dictation pad for testing to see that it recognized the phrase. I tested the phrase without the box open before that.



settings.png
settings.png  (10 KB)



 01/25/2021 08:59 PM
User is offline View Users Profile Print this message

Author Icon
alexander
Advanced Member

Posts: 169
Joined: 07/31/2016

Yes unfortunately the <_anything> trick doesn't work. (I was trying to use it for another purpose which was to forward everything to a different pipe/command)

Mark, that would be a great feature/bug fix for Vocola
 02/01/2021 09:34 AM
User is offline View Users Profile Print this message

Author Icon
renegadevoice
New Member

Posts: 4
Joined: 01/18/2021

Does anyone know if it's just my version of Dragon that's preventing this command from working? Command Mode (only)?
Statistics
31947 users are registered to the KnowBrainer Speech Recognition forum.
There are currently 2 users logged in.
The most users ever online was 12124 on 09/09/2020 at 04:59 AM.
There are currently 519 guests browsing this forum, which makes a total of 521 users using this forum.

FuseTalk Standard Edition v4.0 - © 1999-2021 FuseTalk™ Inc. All rights reserved.